eduCommons on Ubuntu?

classic Classic list List threaded Threaded
9 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

eduCommons on Ubuntu?

chacart
Hi everyone,

Does anybody have installed eduCommons on Ubuntu?

I have tried with Ubuntu 7.04 and Ubuntu 9.04 and I get different errors.

Thank you.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

Santi
Hi, I've got it working on Ubuntu right now.

Which are the problems you've faced? I'll try to make a clean install today so I can tell you which packages I needed to install.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

chacart
Hi Santi,

On Ubuntu 7.04, which is the one I'm more interested in, the error was:

While:
        Installing.
        Getting section instance.
        Initializing section instance.
        Installing recipe plone.recipe.zope2instance.
Error: There is a version conflict.
We already have: zc.buildout 1.1.2
but zc.recipe.egg 1.2.2 requires 'zc.buildout>=1.2.0'

This happens when I get to the "bin/buildout" step of the installation. I think the problem is related to this line at the buildout.cfg:

extends = http://dist.plone.org/release/3.2.3/versions.cfg

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

Sandy Pittendrigh
In reply to this post by chacart
My first stab at an ubuntu installation failed.
I used:

sudo  alien -k eduCommons-3.2.1-final.i386.rpm
to make:
educommons_3.2.1-final-1_i386.deb

Then
sudo dpkg -i educommons_3.2.1-final-1_i386.deb  ....to attempt installation
 
Then
sudo /etc/init.d/educommons start  ....to attempt starting

But the start fails with a variety of errors, starting with "/etc/init.d/functions no such file or directory"

/etc/init.d/educommons does exist, as does /opt/eduCommons-3.2.1

I saw references to a "universal installer" that might be useful for ubuntu installations.
But all the links I can find to various versions of the installer come up as 404 not found.


Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

Tom Caswell
In reply to this post by chacart
Hi all,

I think we have cleared up the eduCommons buildout installation for Ubuntu. Here are the dependencies you need to install first:
python2.4
python2.4-dev
libxml2
libxml2-dev

In buildout.cfg, remove LinguaPlone from [productdistros] and add Products.LinguaPlone==2.1.1 to the eggs section. Brent Lambert is cleaning up a few more things, but I think if you do that much it should work.

Cheers,

Tom
Tom Caswell
http://tomcaswell.com
Open Education Consultant
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

Tapas
Hi Tom thanks for mentioning these packages.
I was trying and got similar errors.

Things had just worked fine when I did
bin/buildout
and got following error

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/opt/eduCommons.buildout-3.2.1-1-final/eggs/zc.buildout-1.4.1-py2.4.egg/zc/buildout/buildout.py", line 1659, in main
    getattr(buildout, command)(args)
  File "/opt/eduCommons.buildout-3.2.1-1-final/eggs/zc.buildout-1.4.1-py2.4.egg/zc/buildout/buildout.py", line 532, in install
    installed_files = self[part]._call(recipe.install)
  File "/opt/eduCommons.buildout-3.2.1-1-final/eggs/zc.buildout-1.4.1-py2.4.egg/zc/buildout/buildout.py", line 1203, in _call
    return f()
  File "/opt/eduCommons.buildout-3.2.1-1-final/eggs/plone.recipe.zope2install-3.0-py2.4.egg/plone/recipe/zope2install/__init__.py", line 205, in install
    f.write(urllib2.urlopen(self.url).read())
  File "/usr/lib/python2.4/urllib2.py", line 130, in urlopen
    return _opener.open(url, data)
  File "/usr/lib/python2.4/urllib2.py", line 364, in open
    response = meth(req, response)
  File "/usr/lib/python2.4/urllib2.py", line 471, in http_response
    response = self.parent.error(
  File "/usr/lib/python2.4/urllib2.py", line 402, in error
    return self._call_chain(*args)
  File "/usr/lib/python2.4/urllib2.py", line 337, in _call_chain
    result = func(*args)
  File "/usr/lib/python2.4/urllib2.py", line 480, in http_error_default
    raise HTTPError(req.get_full_url(), code, msg, hdrs, fp)
HTTPError: HTTP Error 504: Gateway Time-out


I am using Ubuntu 9.04 can you suggest what more is to be done ?
jan
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

jan
in Ubuntu 10.04

and got following error :

While:
  Installing zope2.

An internal error occured due to a bug in either zc.buildout or in a
recipe being used:
Traceback (most recent call last):
  File "/opt/eduCommons.buildout/eggs/zc.buildout-1.4.1-py2.6.egg/zc/buildout/buildout.py", line 1659, in main
    getattr(buildout, command)(args)
  File "/opt/eduCommons.buildout/eggs/zc.buildout-1.4.1-py2.6.egg/zc/buildout/buildout.py", line 532, in install
    installed_files = self[part]._call(recipe.install)
  File "/opt/eduCommons.buildout/eggs/zc.buildout-1.4.1-py2.6.egg/zc/buildout/buildout.py", line 1203, in _call
    return f()
  File "/opt/eduCommons.buildout/eggs/plone.recipe.zope2install-3.0-py2.6.egg/plone/recipe/zope2install/__init__.py", line 226, in install
    ) == 0
AssertionError
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

Carlos Ortega
In reply to this post by chacart
Hi I would like to know the steps to install educommons on Ubuntu 12.10 or Debian, please I need that information.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons on Ubuntu?

blambert
Hello Carlos,

Have you tried pulling down the source tar ball and following the README.txt?

Which version of eduCommons are you trying to install?

Thanks,

Brent

----- Original Message -----
From: "Carlos Ortega [via eduCommons]" <[hidden email]>
To: "blambert" <[hidden email]>
Sent: Friday, December 14, 2012 11:59:32 PM
Subject: Re: eduCommons on Ubuntu?

Hi I would like to know the steps to install educommons on Ubuntu 12.10 or Debian, please I need that information.




If you reply to this email, your message will be added to the discussion below: http://educommons.2416974.n2.nabble.com/eduCommons-on-Ubuntu-tp3668051p7572565.html 
To start a new topic under eduCommons Q&A, email [hidden email]
To unsubscribe from eduCommons, click here .
NAML
Loading...