eduCommons & Debian.

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

eduCommons & Debian.

memoKnto
This post was updated on .
Hello everyone! I'm in a middle of a battle between debian and the source install. So far so good -  i got all the depndencies and libraries that i found in the Ubuntu messages ( here in teh forum) ...and also get all the build essential - running the bootstrap.py, and there were no problems...but then with the buildout, after installing zope.. i got this error:

Updating zope2.
Updating fake eggs
Updating productdistros.
Installing instance.
Getting distribution for 'libxml2-python==2.6.15'.
/usr/lib/python2.4/xmllib.py:9: DeprecationWarning: The xmllib module is obsolete.  Use xml.sax instead.
  warnings.warn("The xmllib module is obsolete.  Use xml.sax instead.", DeprecationWarning)
Found 1494 functions in libxml2-api.xml
Found 53 functions in libxml2-python-api.xml
Generated 848 wrapper functions, 495 failed, 204 skipped

Missing type converters:
xmlRelaxNGValidityErrorFunc *:2  xmlXPathObjectPtr:22  const htmlEntityDesc *:2  xmlOutputMatchCallback:1  xmlElementContentPtr *:1  xmlStructuredErrorFunc:1  xmlParserInputBufferCreateFilenameFunc:2  xmlSchemaValType:1  size_t:1  xmlSchemaWildcardPtr:1  xmlXIncludeCtxtPtr:4  xmlRelaxNGValidityErrorFunc:2  xmlSAXHandler *:4  ...:1  xmlShellReadlineFunc:1  xmlDict *:1  xmlAutomataPtr:18  xmlParserInputPtr:17  xmlCatalogAllow:2  xmlElementContent *:1  xmlCharEncodingOutputFunc:1  xmlDictPtr:8  xmlTextWriterPtr:77  const htmlElemDesc *:1  xmlSchemaValPtr:2  xmlInputMatchCallback:1  xmlElementTablePtr:2  xmlChar **:15  xmlXPathCompExprPtr:5  xmlTextReaderErrorFunc:1  xmlExternalEntityLoader:2  xmlNotationTablePtr:2  xmlXPathVariableLookupFunc:1  xmlParserNodeInfoPtr:1  xmlPatternPtr:3  xmlValidCtxtPtr:25  xmlC14NIsVisibleCallback:1  xmlDeregisterNodeFunc:2  va_list:1  xmlSchemaTypePtr:9  htmlStatus:1  xmlRegisterNodeFunc:2  xmlAttributeType:1  xmlCharEncodingHandler *:4  xmlNotationPtr:1  xmlRegExecCallbacks:1  xmlNsPtr *:1  xmlLocationSetPtr:6  xmlEnumerationPtr:5  xmlEnumerationPtr *:2  xmlShellCtxtPtr:10  xlinkNodeDetectFunc:2  xmlRefTablePtr:1  xmlSchemaValidityErrorFunc *:2  xmlChRangeGroupPtr:1  xmlAttributeTablePtr:2  xmlCatalogPrefer:1  xmlParserNodeInfoSeqPtr:3  xmlNodePtr *:2  xmlInputReadCallback:7  char **:5  xmlCharEncoding:13  xmlRegExecCtxtPtr:3  xmlElementContentType:1  void *:85  xmlTextReaderErrorFunc *:1  xmlSaveCtxtPtr:8  xmlEntityReferenceFunc:1  xmlDocPtr *:1  xmlBufferAllocationScheme:3  xmlSchemaValidityErrorFunc:2  xmlOutputWriteCallback:2  xmlSchemaFacetPtr:5  xlinkHandlerPtr:2  xmlXPathFuncLookupFunc:1  htmlElemDesc *:3  xmlCharEncodingHandlerPtr:7  xmlCharEncodingInputFunc:1  const xmlParserNodeInfo *:1  xmlNodeSetPtr:32  xmlEntitiesTablePtr:3  xmlIDTablePtr:1  xmlXPathFunction:4  xmlOutputBufferCreateFilenameFunc:2  xmlElementContentPtr:6  xlinkType:1  xmlGenericErrorFunc *:1
Found 216 functions in libxslt-api.xml
Found 27 functions in libxslt-python-api.xml
Generated 126 wrapper functions, 84 failed, 33 skipped

Missing type converters:
xsltTopLevelFunction:2  xsltDecimalFormatPtr:2  xmlChar **:2  xmlXPathCompExprPtr:4  xsltPreComputeFunction:1  xsltElemPreCompPtr:2  xsltDebugTraceCodes:2  xsltSortFunc:2  xsltSecurityPrefsPtr:11  xsltTemplatePtr:4  pythonObject *:4  xsltDocLoaderFunc:1  ...:1  xsltNumberDataPtr:1  xmlNodePtr *:3  xsltExtInitFunction:2  char **:2  xmlXPathObjectPtr *:1  xmlNodeSetPtr:2  xmlXPathFunction:4  xsltTransformFunction:5  xsltCompMatchPtr:3  void *:10  xmlOutputBufferPtr:1  xmlHashTablePtr:1  xmlDictPtr:1  xsltDocumentPtr:7  xsltStackElemPtr:3
/usr/lib/python2.4/distutils/dist.py:222: UserWarning: 'licence' distribution option is deprecated; use 'license'
  warnings.warn(msg)
libxml2-py.c: In function ‘libxml_xmlUTF8Strpos’:
libxml2-py.c:12272: warning: assignment discards qualifiers from pointer target type
/usr/bin/ld: cannot find -lz
collect2: ld returned 1 exit status
error: Setup script exited with error: command 'gcc' failed with exit status 1
An error occured when trying to install libxml2-python 2.6.15.Look above this message for any errors thatwere output by easy_install.
While:
  Installing instance.
  Getting distribution for 'libxml2-python==2.6.15'.
Error: Couldn't install: libxml2-python 2.6.15


And pop me out of the installation. any clue? i tried to get all the libs i can but still getting this issue.

thanks!
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons & Debian.

memoKnto
i'm giving up! No matter what i try i can not be able to install eduCommons in debian. I belive i should try in another distro.
Loading...