eduCommons-3.2.1-1.x86_64 on CentOS 4.7

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

eduCommons-3.2.1-1.x86_64 on CentOS 4.7

Gustavo Morales
Hi,

I am trying to install eduCommons-3.2.1-1.x86_64 on CentOS 4.7 64-bits, previously install and update all required libraries in the instructions through YUM, but in the final step I get this message:

[root@algorrobo1 Desktop]# rpm -ivh eduCommons-3.2.1-1.x86_64.rpm

error: Failed dependencies:
        /usr/bin/python2.4 is needed by eduCommons-3.2.1-1.x86_64
        libc.so.6(GLIBC_2.4)(64bit) is needed by eduCommons-3.2.1-1.x86_64
        rtld(GNU_HASH) is needed by eduCommons-3.2.1-1.x86_64
[root@algorrobo1 Desktop]#

Thanks for any help
--
GJ
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons-3.2.1-1.x86_64 on CentOS 4.7

blambert
Hello Gustavo,

The RPM you are trying to install is built explicitly for CentOS 5.x. The errors you are seeing are failed dependencies that are not met with CentOS 4.x. You might want to look at the following discussion that talks about the challenges of running the right version of Python on CentOS 4.x:

http://grokbase.com/topic/2008/03/11/centos-python-2-4-on-centos4/FvH6KQklUA9OyVQ42hguKXu8iqQ

Is there a specific reason you are using 4.x and not a more modern 5.x version?

If you really are stuck using 4.x than the only way forward is to pull down the source buildout and follow the directions and compile your own version of Python-2.4.x, as well as all the other dependencies.

Hope that helps,

Brent

Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: eduCommons-3.2.1-1.x86_64 on CentOS 4.7

Gustavo Morales
Thanks,

I download "eduCommons.buildout-3.2.1-1-final.tar.gz" and follow the instructions to install but in this step
bin/buildout -c tests,cfg
Show that:
....
Installing instance.
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Download error: [Errno 111] Connection refused -- Some packages may not be found!
Getting distribution for 'mocker==0.10.1'.
While:
  Installing instance.
  Getting distribution for 'mocker==0.10.1'.
Error: Couldn't find a distribution for 'mocker==0.10.1'.
--
GJ
Loading...