Solved : embedded html code for serving flash in eduCommons was deleted by eduCommons itself

classic Classic list List threaded Threaded
2 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Solved : embedded html code for serving flash in eduCommons was deleted by eduCommons itself

Tapas
This post was updated on .
I am testing eduCommons embedding flash files in eduCommons.
For this I created a demo environment on a Windows machine.
Installed eduCommons windows exe.

I have few static html pages which can play the flash files very well.

Here is the html code

<object classid='clsid:D27CDB6E-AE6D-11cf-96B8-444553540000' width='470' height='290' id='single1' name='single1'>
<param name='movie' value='http://localhost:8080/eduCommons/player.swf'>
<param name='allowfullscreen' value='true'>
<param name='allowscriptaccess' value='always'>
<param name='wmode' value='transparent'>
<param name='flashvars' value='file=/Courses/video1.flv&streamer=rtmp://_internal_stream_on_lan'>

<embed type='application/x-shockwave-flash' id='single2' name='single2' 
 src='http://localhost:8080/eduCommons/player.swf' width='470' height='290' bgcolor='undefined' 
allowscriptaccess='always' allowfullscreen='true' wmode='transparent'  
 flashvars='file=/Courses/video1.flv&streamer=rtmp://_internal_stream_on_lan' />

</object>


I could see the videos when I am using above html code in static html pages.

Now I copy pasted the above html  in some pages on eduCommons I move through the workflow and publish the document but I do not get desired
the movie.

I checked this thread

http://educommons.2416974.n2.nabble.com/Allowing-embed-tags-object-tags-script-tags-and-javascript-in-eduCommons-tp3530842p3530842.html

even though I go through HTMLFilter and many many times I try to add object tag to Custom Tag sections it will not save.
Also the problem is if I save the above code and when I check the source of final page as a user on internet would see my html pages I see embed tag is stripped off.

Hence the flash could not be embedded  properly. As a result I was unable to see the flash movie in firefox. I was able to see the same movie when I opened eduCommons  using Internet Explorer as client browser.
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: problem in embedding flash in eduCommon on Windows package

Tapas
This post was updated on .
Okay finally fixed this problem myself.

Though the site can be seen playing videos in Internet Explorer but the video/flash wont work in Firefox.


After wasting one complete day for this reading for n number of documents on this planet which ever I got  until  I  opned firefox and went to same page where I embeded the html
again meaning I edited the same page and to fix the delted part of html I copy pasted the script
but I did above in Firefox not by using Internet explorer.


This time I was able to see the flash movie in Firefox and Internet Explorer both.

The portion of html which  which I mentioned above was getting stripped of when I saved the embeded html using Internet Explorer was present in page source this time.


Having said that I will also tell that even when embed section of html was getting stripped off via eduCommons the flash video still was seen in Chrome.

Editing of html is to embed flash in eduCommons depends upon the browser being used.
If you open the eduCommons package as admin then you will see a warning which says

"there is no guarente that your embeded HTML code will be saved"

Meaning if you embed the html for the  eduCommons rpm on a CentOS machine using firefox.
Then there is a high probability that you do not see flash movies (or exact html which you embeded ) in Internet explorer  while you will continue to see the flash movie in Firefox and Chrome.

To fix this you get a windows machine and login to your eduCommons production server as admin and embed the above HTML code (which serves the flash movie) using Internet Explorer.
This type of problems will go.


Similary if you are have your  eduCommons production server is on  windows.
Then do use firefox to embed the html code which will serve the flash files.
Other wise you will not be able to see any video in Firefox this time but will  to see in IE .

Also make sure you have Adobe latest flash player plugin installed.
Until I had figured out both of these I had wasted a lot of time for this.
Loading...