Load testing

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

Load testing

P Barrera
Hi,
I want to know where I can find the reports containing the load test results. Load test was assigned to release 3.2.1
Thanks
Reply | Threaded
Open this post in threaded view
|

Re: Load testing

Tom Caswell
Hello,

I will look into this, but I think the load test reports will only be useful if you have the same exact configuration. You may want to run your own load tests by navigating to Site Setup -->portal_loadtesttool. First use the "Load Content" tab, then use the "Run Test" tab to run the actual tests.

Cheers,

Tom
Tom Caswell
http://tomcaswell.com
Open Education Consultant
Reply | Threaded
Open this post in threaded view
|

Re: Load testing

P Barrera
Hi,
I’ve run load tests against my eduCommons pilot site and now I’ve got the reports of this site. But I’m not sure about how to configure a production site. For example, how much additional RAM to increase the number of requests/sec and improve average load time.

I’d appreciate people running these tests and sharing reports. Mine are here:

*Pilot site: desktop platform (Core 2 Duo 2,13GHz with only one SATA disk), 1GB RAM, eduCommons 3.2.1 for Windows.

*Tests run: 10 URLs, including front page, course list, help, divisions and course resources. 15 repetitions (150 requests).

*Tests results:
>Average Load Time: from 0.14 sec to 0.28 sec.
>Shortest Load Time: 0.125 sec.
>Longest Load Time: 0.531 sec.
>Requests/Second: 4.9

Regards