Application Couldn't install Five

classic Classic list List threaded Threaded
10 messages Options
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Application Couldn't install Five

Kursat
As you understand still I am trying to install eduCommons by using Plone-3.2.2.2-UnifiedInstaller. I already wrote my former post in another topic, but in order to other users can benefit by the solutions I created another topic.

I can't still use eduCommons products. The traceback is:

instance: /usr/local/Plone/zinstance/parts/instance/bin/runzope -X debug-mode=on
2009-06-23 14:25:39 INFO ZServer HTTP server started at Tue Jun 23 14:25:39 2009
        Hostname: 0.0.0.0
        Port: 8080
2009-06-23 14:25:39 INFO Zope Set effective user to "plone"
2009-06-23 14:25:46 WARNING PlacelessTranslationService Error while compiling /usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/app/locales/zh_CN/LC_MESSAGES/zope.po

2009-06-23 14:25:48 ERROR Application Couldn't install Five
Traceback (most recent call last):
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 786, in install_product
    initmethod(context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/__init__.py", line 28, in initialize
    zcml.load_site()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/zcml.py", line 53, in load_site
    _context = xmlconfig.file(file)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 579, in file
    include(context, name, package)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 515, in include
    processxmlfile(f, context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 370, in processxmlfile
    parser.parse(src)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 107, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 207, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 348, in end_element_ns
    self._cont_handler.endElementNS(pair, None)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 349, in endElementNS
    self.context.end()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 544, in end
    self.stack.pop().finish()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 692, in finish
    actions = self.handler(context, **args)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/fiveconfigure.py", line 78, in loadProducts
    handleBrokenProduct(product)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/fiveconfigure.py", line 76, in loadProducts
    xmlconfig.include(_context, zcml, package=product)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 515, in include
    processxmlfile(f, context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 370, in processxmlfile
    parser.parse(src)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 107, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 207, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 348, in end_element_ns
    self._cont_handler.endElementNS(pair, None)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 349, in endElementNS
    self.context.end()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 544, in end
    self.stack.pop().finish()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 691, in finish
    args = toargs(context, *self.argdata)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 1383, in toargs
    args[str(name)] = field.fromUnicode(s)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/fields.py", line 139, in fromUnicode
    value = self.context.resolve(name)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 184, in resolve
    mod = __import__(mname, *_import_chickens)
  File "/usr/local/Plone/zinstance/parts/productdistros/IMSTransport/TransformHandlers.py", line 37, in ?
    from xml.xpath import Evaluate
ZopeXMLConfigurationError: File "/usr/local/Plone/zinstance/parts/instance/etc/site.zcml", line 15.2-15.23
    ZopeXMLConfigurationError: File "/usr/local/Plone/zinstance/parts/productdistros/IMSTransport/configure.zcml", line 51.2-53.59
    ImportError: No module named xpath
Traceback (most recent call last):
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/Startup/run.py", line 56, in ?
    run()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/Startup/run.py", line 21, in run
    starter.prepare()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/Startup/__init__.py", line 102, in prepare
    self.startZope()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/Startup/__init__.py", line 278, in startZope
    Zope2.startup()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/__init__.py", line 47, in startup
    _startup()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Zope2/App/startup.py", line 102, in startup
    OFS.Application.initialize(application)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 309, in initialize
    initializer.initialize()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 338, in initialize
    self.install_products()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 603, in install_products
    return install_products(app)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 634, in install_products
    folder_permissions, raise_exc=debug_mode)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/OFS/Application.py", line 786, in install_product
    initmethod(context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/__init__.py", line 28, in initialize
    zcml.load_site()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/zcml.py", line 53, in load_site
    _context = xmlconfig.file(file)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 579, in file
    include(context, name, package)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 515, in include
    processxmlfile(f, context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 370, in processxmlfile
    parser.parse(src)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 107, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 207, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 348, in end_element_ns
    self._cont_handler.endElementNS(pair, None)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 349, in endElementNS
    self.context.end()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 544, in end
    self.stack.pop().finish()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 692, in finish
    actions = self.handler(context, **args)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/fiveconfigure.py", line 78, in loadProducts
    handleBrokenProduct(product)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/Products/Five/fiveconfigure.py", line 76, in loadProducts
    xmlconfig.include(_context, zcml, package=product)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 515, in include
    processxmlfile(f, context)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 370, in processxmlfile
    parser.parse(src)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 107, in parse
    xmlreader.IncrementalParser.parse(self, source)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/xmlreader.py", line 123, in parse
    self.feed(buffer)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 207, in feed
    self._parser.Parse(data, isFinal)
  File "/usr/local/Plone/Python-2.4/lib/python2.4/xml/sax/expatreader.py", line 348, in end_element_ns
    self._cont_handler.endElementNS(pair, None)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/xmlconfig.py", line 349, in endElementNS
    self.context.end()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 544, in end
    self.stack.pop().finish()
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 691, in finish
    args = toargs(context, *self.argdata)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 1383, in toargs
    args[str(name)] = field.fromUnicode(s)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/fields.py", line 139, in fromUnicode
    value = self.context.resolve(name)
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/zope/configuration/config.py", line 184, in resolve
    mod = __import__(mname, *_import_chickens)
  File "/usr/local/Plone/zinstance/parts/productdistros/IMSTransport/TransformHandlers.py", line 37, in ?
    from xml.xpath import Evaluate
zope.configuration.xmlconfig.ZopeXMLConfigurationError: File "/usr/local/Plone/zinstance/parts/instance/etc/site.zcml", line 15.2-15.23
    ZopeXMLConfigurationError: File "/usr/local/Plone/zinstance/parts/productdistros/IMSTransport/configure.zcml", line 51.2-53.59
    ImportError: No module named xpath


Thank you very much for all..
Kursat Hosel
Universidad de Alcala
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

David Ray
Administrator
Kursat:

It sounds like you are missing PyXML.

Since you are using the unified installer, you can add PyXML to your buildout quite easily by adding the following, and rerunning buildout:

find-links =
    http://ufpr.dl.sourceforge.net/sourceforge/pyxml/PyXML-0.8.4.tar.gz

eggs =
    PyXML
---------------------
David Ray
Applications Analyst
Lineberger Comprehsensive Cancer Center
University of North Carolina at Chapel Hill
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

Kursat
Hi David,

I think it worked. Thank you very much.
Now I have a new problem. When I try to access the site web-page shows that:
-----------------------------------------------------------------------------------------------------------
Site Error

An error was encountered while publishing this resource.

Error Type: AttributeError
Error Value: __getitem__

Troubleshooting Suggestions

    * The URL may be incorrect.
    * The parameters passed to this resource may be incorrect.
    * A resource that this resource relies on may be encountering an error.

For more detailed information about the error, please refer to the error log.

If the error persists please contact the site maintainer. Thank you for your patience.
-----------------------------------------------------------------------------------------------------------

And the traceback is:

2009-06-24 11:46:30 ERROR ZPublisher BeforeTraverse: Error while invoking hook: "acl_users"
Traceback (most recent call last):
  File "/usr/local/Plone/Zope-2.10.7-final-py2.4/lib/python/ZPublisher/BeforeTraverse.py", line 145, in __call__
    meth(*(container, request, None)[:args])
AttributeError: __call__
2009-06-24 11:46:30 ERROR Zope.SiteErrorLog http://site_name/index_html
Traceback (innermost last):
  Module ZPublisher.Publish, line 110, in publish
  Module ZPublisher.BaseRequest, line 581, in traverse
  Module ZPublisher.BaseRequest, line 686, in old_validation
AttributeError: __getitem__

I am again looking forward your solutions, thank you so much.

Kursat Hosel
Universidad de Alcala
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

David Ray
Administrator
Are you working with any additional Plone products beside the eduCommons suite?  We have not seen this particular error before.

It looks as though your acl_users object is missing.  If you navigate to the eduCommons site in the ZMI, do you have an acl_users object?



---------------------
David Ray
Applications Analyst
Lineberger Comprehsensive Cancer Center
University of North Carolina at Chapel Hill
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

Kursat
No, I just want to work with eduCommons. Before unzip the eduCommons product I could see everything. I could even change usernames, passwords, etc. There was not any problem about acl_users.
Now, as I sent before I can't reach the ZMI on home page. It prompts me to enter username and password but nothing else.
As I told you before I am a newby on Linux too. So I use the chmod on buildout file in order to modify it.

chmod 666 buildout
I made.

Does it cause a problem you think? Maybe I did some mischief on file permissions. Is there some rule about the file permissions like instance or buildout files has to have something?

Thank you so much for everything.
Kursat Hosel
Universidad de Alcala
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

David Ray
Administrator
While we typically wouldn't advocate those permissions in a production environment, I don't think it should be causing that error.

Restart your zope instance in foreground mode, and see if the terminal provides any additional tracebacks:

/bin/instance fg
---------------------
David Ray
Applications Analyst
Lineberger Comprehsensive Cancer Center
University of North Carolina at Chapel Hill
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

Kursat
Hi David,

Firstly I really want to thank you million times.

when I bin/instance fg it prints:

/usr/local/Plone/zinstance/parts/instance/bin/runzope -X debug-mode=on
2009-06-25 12:49:18 INFO ZServer HTTP server started at Thu Jun 25 12:49:18 2009
        Hostname: 0.0.0.0
        Port: 8080
2009-06-25 12:49:18 INFO Zope Set effective user to "plone"
2009-06-25 12:49:20 WARNING OFS.Uninstalled Could not import class 'PloneSite' from module 'Products.CMFPlone.Portal'
2009-06-25 12:49:20 WARNING OFS.Uninstalled Could not import class 'PluggableAuthService' from module 'Products.PluggableAuthService.PluggableAuthService'
2009-06-25 12:49:20 WARNING OFS.Uninstalled Could not import class 'ViewTemplateContainer' from module 'plone.app.customerize.tool'
2009-06-25 12:49:20 WARNING OFS.Uninstalled Could not import class 'PlacelessTranslationService' from module 'Products.PlacelessTranslationService.PlacelessTranslationService'
2009-06-25 12:49:20 INFO Zope Ready to handle requests


I didn't take these warnings into considering. Because of "zope ready to handle requests" I tried to access to site. And you know what happens when I try... The interesting thing it prompts me to enter username and password. So can we say that zope works properly but there is a mistake about acl_users? I mean it looks like (I don't know the structure of zope I will use word "database" for it) there is no users' database in it. It was deleted somehow..


-------------------------------------------------------------------------------------------------------------------------------

In the meantime I try to install eduCommons by following the instructions at http://educommons.com/documentation/how-to/installation-instructions .

When I ./zopectl fg the traceback is:

/opt/Zope-2.10.5/web/bin/runzope -X debug-mode=on
2009-06-25 13:08:13 INFO ZServer HTTP server started at Thu Jun 25 13:08:13 2009
        Hostname: 0.0.0.0
        Port: 8080
2009-06-25 13:08:14 INFO Zope Set effective user to "zope"
2009-06-25 13:08:17 ERROR PortalTransforms Problem importing module web_intelligent_plain_text_to_html : No module named intelligenttext.transforms
2009-06-25 13:08:17 ERROR PortalTransforms Problem importing module html_to_web_intelligent_plain_text : No module named intelligenttext.transforms
2009-06-25 13:08:18 ERROR Application Could not import Products.ATContentTypes
Traceback (most recent call last):
  File "/opt/Zope-2.10.5/lib/python/OFS/Application.py", line 709, in import_product
    product=__import__(pname, global_dict, global_dict, silly)
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/__init__.py", line 64, in ?
    import Products.ATContentTypes.content
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/__init__.py", line 26, in ?
    import Products.ATContentTypes.content.link
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/link.py", line 39, in ?
    from Products.ATContentTypes.content.base import registerATCT
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/base.py", line 63, in ?
    from Products.CMFPlone.PloneFolder import ReplaceableWrapper
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/__init__.py", line 215, in ?
    from browser import ploneview
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/browser/ploneview.py", line 12, in ?
    from Products.CMFPlone import utils
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/utils.py", line 7, in ?
    from plone.i18n.normalizer.interfaces import IIDNormalizer
ImportError: No module named i18n.normalizer.interfaces
Traceback (most recent call last):
  File "/opt/Zope-2.10.5/lib/python/Zope2/Startup/run.py", line 56, in ?
    run()
  File "/opt/Zope-2.10.5/lib/python/Zope2/Startup/run.py", line 21, in run
    starter.prepare()
  File "/opt/Zope-2.10.5/lib/python/Zope2/Startup/__init__.py", line 102, in prepare
    self.startZope()
  File "/opt/Zope-2.10.5/lib/python/Zope2/Startup/__init__.py", line 278, in startZope
    Zope2.startup()
  File "/opt/Zope-2.10.5/lib/python/Zope2/__init__.py", line 47, in startup
    _startup()
  File "/opt/Zope-2.10.5/lib/python/Zope2/App/startup.py", line 45, in startup
    OFS.Application.import_products()
  File "/opt/Zope-2.10.5/lib/python/OFS/Application.py", line 686, in import_products
    import_product(product_dir, product_name, raise_exc=debug_mode)
  File "/opt/Zope-2.10.5/lib/python/OFS/Application.py", line 709, in import_product
    product=__import__(pname, global_dict, global_dict, silly)
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/__init__.py", line 64, in ?
    import Products.ATContentTypes.content
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/__init__.py", line 26, in ?
    import Products.ATContentTypes.content.link
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/link.py", line 39, in ?
    from Products.ATContentTypes.content.base import registerATCT
  File "/opt/Zope-2.10.5/web/Products/ATContentTypes/content/base.py", line 63, in ?
    from Products.CMFPlone.PloneFolder import ReplaceableWrapper
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/__init__.py", line 215, in ?
    from browser import ploneview
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/browser/ploneview.py", line 12, in ?
    from Products.CMFPlone import utils
  File "/opt/Zope-2.10.5/web/Products/CMFPlone/utils.py", line 7, in ?
    from plone.i18n.normalizer.interfaces import IIDNormalizer
ImportError: No module named i18n.normalizer.interfaces

Thanks for all.


Kursat Hosel
Universidad de Alcala
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

Kursat
Hey David,

I fixed the 2nd installation problem by using
cp -R /opt/Zope-2.10.5/web/lib/python/* /opt/Zope-2.10.5/lib/python/

Now it seems OK. Thank you very much for all. But if you are still curios about the first problem we can try to solve it together in order to other users of eduCommons benefit by.

I hope there will not be any other problem. Thank you very much for all.
Kursat Hosel
Universidad de Alcala
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

David Ray
Administrator
Glad to hear that you got your installation up and running.

The next release of eduCommons is due out soon (around Aug 1).  This release will be buildout based, and should solve many of the current installation hiccups.

David
---------------------
David Ray
Applications Analyst
Lineberger Comprehsensive Cancer Center
University of North Carolina at Chapel Hill
Reply | Threaded
Open this post in threaded view
|  
Report Content as Inappropriate

Re: Application Couldn't install Five

Dizi
I posted it on a special dizi izle  getpaid-dev forum. The people there informed me that they haven't hanimin ciftligi izle upgraded the anonymous version for a long time. The files there need to be refreshed. They did it. Therefore, my problem has been solved.
Loading...